Joomla 4.1.2 and 3.10.8 Release

Joomla 4.1.2 & 3.10.8 is now available. This is a security release for both the 4.x and the 3.x series of Joomla which address a few security vulnerabilities and contains various bug fixes and improvements.

What's in 4.1.2?

Joomla 4.1.2 includes all security patches from 4.1.1 except 20220303 that has been reverted due to implementation issues.

Security Issues Fixed with 4.1.1

  • [20220301] Low Severity - Moderate Impact - Zip Slip within the Tar extractor (affecting Joomla! 3.0.0 through 3.10.6 & 4.0.0 through 4.1.0) More information
  • [20220302] Low Severity - Low Impact - Path Disclosure within filesystem error messages (affecting Joomla! 3.0.0 through 3.10.6 & 4.0.0 through 4.1.0) More information
  • [20220305] Low Severity - High Impact - Inadequate filtering on the selected Ids (affecting Joomla! 3.0.0 through 3.10.6 & 4.0.0 through 4.1.0) More information
  • [20220306] Low Severity - Low Impact - Inadequate validation of internal URLs  (affecting Joomla! 2.5.0 through 3.10.6 & 4.0.0 through 4.1.0) More information
  • [20220307] Low Severity - Moderate Impact - Variable Tampering on JInput $_REQUEST data (affecting Joomla! 4.0.0 through 4.1.0) More information
  • [20220308] Low Severity - Moderate Impact - Inadequate content filtering within the filter code  (affecting Joomla! 4.0.0 through 4.1.0) More information
  • [20220309] Low Severity - Moderate Impact - XSS attack vector through SVG (affecting Joomla! 4.0.0 through 4.1.0) More information

Bug fixes and Improvements

  • Fix language strings behaviour in TinyMCE
  • Fix switch for syntax highlighting in TinyMCE
  • Show failed tasks in scheduler
  • Correct usage of Jooa11y parameters
  • Codemirror enhancements
  • Several 8.x PHP fixes

Visit GitHub for the full list of bug fixes.

What’s in 3.10.8?

Joomla 3.10.8 includes all security patches from 3.10.7 except 20220303 that has been reverted due to implementation issues:

Security Issues Fixed with 3.10.7

  • [20220301] Low Severity - Moderate Impact - Zip Slip within the Tar extractor (affecting Joomla! 3.0.0 through 3.10.6 & 4.0.0 through 4.1.0) More information
  • [20220302] Low Severity - Low Impact - Path Disclosure within filesystem error messages (affecting Joomla! 3.0.0 through 3.10.6 & 4.0.0 through 4.1.0) More information
  • [20220304] Low Severity - Moderate Impact - Missing input validation within com_fields class inputs (affecting Joomla! 3.7.0 through 3.10.6) More information
  • [20220305] Low Severity - High Impact - Inadequate filtering on the selected Ids (affecting Joomla! 3.0.0 through 3.10.6 & 4.0.0 through 4.1.0) More information
  • [20220306] Low Severity - Low Impact - Inadequate validation of internal URLs  (affecting Joomla! 2.5.0 through 3.10.6 & 4.0.0 through 4.1.0) More information

Bug fixes and Improvements with 3.10.7

Visit GitHub for the full list of bug fixes.

Where can I download Joomla 4.1.2 and the latest update of Joomla 3.10 series, Joomla 3.10.8?